<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<script src="/cdn-cgi/apps/head/iG-iQ02cfbQBfzhdK4GFkz3YTB0.js"></script><link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.kttn.com/xmlrpc.php">
</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Social Warfare v4.3.0 https://warfareplugins.com - BEGINNING OF OUTPUT -->
<style>
	@font-face {
		font-family: "sw-icon-font";
		src:url("https://www.kttn.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0");
		src:url("https://www.kttn.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.eot?ver=4.3.0#iefix") format("embedded-opentype"),
		url("https://www.kttn.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.woff?ver=4.3.0") format("woff"),
		url("https://www.kttn.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.ttf?ver=4.3.0") format("truetype"),
		url("https://www.kttn.com/wp-content/plugins/social-warfare/assets/fonts/sw-icon-font.svg?ver=4.3.0#1445203416") format("svg");
		font-weight: normal;
		font-style: normal;
		font-display:block;
	}
</style>
<!-- Social Warfare v4.3.0 https://warfareplugins.com - END OF OUTPUT -->

<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="rsYlpleW12O6JgQKtexRNQeAFPdXXM46fsLgX_Nf17g" />

	<!-- This site is optimized with the Yoast SEO Premium plugin v19.6 (Yoast SEO v19.13) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Obituary &amp; Services: Clarence Randall Mantzey, Jr</title>
	<link rel="canonical" href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Obituary &amp; Services: Clarence Randall Mantzey, Jr" />
	<meta property="og:description" content="Clarence Randall Mantzey, Jr., a resident of Chillicothe, Missouri, passed away Sunday, December 25, 2022, at his residence. Clarence was born the son of" />
	<meta property="og:url" content="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" />
	<meta property="og:site_name" content="KTTN-FM 92.3 and KGOZ -FM 101.7" />
	<meta property="article:publisher" content="https://www.facebook.com/kttnfm/" />
	<meta property="article:published_time" content="2022-12-29T18:23:00+00:00" />
	<meta property="article:modified_time" content="2022-12-29T18:24:56+00:00" />
	<meta property="og:image" content="https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg" />
	<meta property="og:image:width" content="770" />
	<meta property="og:image:height" content="440" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="KTTN News" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@KTTNRadio" />
	<meta name="twitter:site" content="@KTTNRadio" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="KTTN News" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"NewsArticle","@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#article","isPartOf":{"@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/"},"author":{"name":"KTTN News","@id":"https://www.kttn.com/#/schema/person/20a8c58197d754331121facf97886307"},"headline":"Obituary &#038; Services: Clarence Randall Mantzey, Jr","datePublished":"2022-12-29T18:23:00+00:00","dateModified":"2022-12-29T18:24:56+00:00","mainEntityOfPage":{"@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/"},"wordCount":272,"commentCount":0,"publisher":{"@id":"https://www.kttn.com/#organization"},"image":{"@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#primaryimage"},"thumbnailUrl":"https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg","articleSection":["Obituaries"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#respond"]}]},{"@type":"WebPage","@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/","url":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/","name":"Obituary & Services: Clarence Randall Mantzey, Jr","isPartOf":{"@id":"https://www.kttn.com/#website"},"primaryImageOfPage":{"@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#primaryimage"},"image":{"@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#primaryimage"},"thumbnailUrl":"https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg","datePublished":"2022-12-29T18:23:00+00:00","dateModified":"2022-12-29T18:24:56+00:00","breadcrumb":{"@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#primaryimage","url":"https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg","contentUrl":"https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg","width":770,"height":440,"caption":"Clarence Randall Mantzey obit photo"},{"@type":"BreadcrumbList","@id":"https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.kttn.com/"},{"@type":"ListItem","position":2,"name":"Obituaries","item":"https://www.kttn.com/category/obits/"},{"@type":"ListItem","position":3,"name":"Obituary &#038; Services: Clarence Randall Mantzey, Jr"}]},{"@type":"WebSite","@id":"https://www.kttn.com/#website","url":"https://www.kttn.com/","name":"KTTN-FM 92.3 and KGOZ -FM 101.7","description":"Serving North Missouri","publisher":{"@id":"https://www.kttn.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.kttn.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://www.kttn.com/#organization","name":"KTTN Radio","url":"https://www.kttn.com/","logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.kttn.com/#/schema/logo/image/","url":"https://www.kttn.com/wp-content/uploads/2016/02/mk-1-1.png","contentUrl":"https://www.kttn.com/wp-content/uploads/2016/02/mk-1-1.png","width":300,"height":100,"caption":"KTTN Radio"},"image":{"@id":"https://www.kttn.com/#/schema/logo/image/"},"sameAs":["https://www.youtube.com/user/KTTNRadio","https://en.wikipedia.org/wiki/KTTN-FM","https://www.facebook.com/kttnfm/","https://twitter.com/KTTNRadio"]},{"@type":"Person","@id":"https://www.kttn.com/#/schema/person/20a8c58197d754331121facf97886307","name":"KTTN News","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.kttn.com/#/schema/person/image/","url":"https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-110x110.png","contentUrl":"https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-110x110.png","caption":"KTTN News"},"sameAs":["http://www.kttn.com"],"url":"https://www.kttn.com/author/kttn-news/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="KTTN-FM 92.3 and KGOZ -FM 101.7  &raquo; Feed" href="https://www.kttn.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KTTN-FM 92.3 and KGOZ -FM 101.7  &raquo; Comments Feed" href="https://www.kttn.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="KTTN-FM 92.3 and KGOZ -FM 101.7  &raquo; Obituary &#038; Services: Clarence Randall Mantzey, Jr Comments Feed" href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.kttn.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='mb.miniAudioPlayer.css-css' href='https://www.kttn.com/wp-content/plugins/wp-miniaudioplayer/css/miniplayer.css?ver=1.9.7' type='text/css' media='screen' />
<link rel='stylesheet' id='mediaelement-css' href='https://www.kttn.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.17' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css' href='https://www.kttn.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.kttn.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='dw-megamenu-front-end-style-css' href='https://www.kttn.com/wp-content/plugins/dw-megamenu/assets/css/dw-megamenu.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw-social-share-css' href='https://www.kttn.com/wp-content/plugins/dw-social-share/assets/css/style.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.kttn.com/wp-includes/css/dashicons.min.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://www.kttn.com/wp-content/plugins/post-views-counter/css/frontend.min.css?ver=1.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='social_warfare-css' href='https://www.kttn.com/wp-content/plugins/social-warfare/assets/css/style.min.css?ver=4.3.0' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-main-css' href='https://www.kttn.com/wp-content/themes/dw-focus/assets/css/dw-focus.min.css?ver=1.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-style-css' href='https://www.kttn.com/wp-content/themes/dw-focus/style.css?ver=6.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='dw-focus-print-css' href='https://www.kttn.com/wp-content/themes/dw-focus/assets/css/print.css?ver=1.4.1' type='text/css' media='print' />
<link rel='stylesheet' id='dw-focus-fonts-css' href='//fonts.googleapis.com/css?family=Roboto+Slab' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='social-logos-css' href='https://www.kttn.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=11.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.kttn.com/wp-content/plugins/jetpack/css/jetpack.css?ver=11.6' type='text/css' media='all' />
<script type='text/javascript' src='https://www.kttn.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/wp-miniaudioplayer/js/jquery.mb.miniAudioPlayer.js?ver=1.9.7' id='mb.miniAudioPlayer-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/wp-miniaudioplayer/js/map_overwrite_default_me.js?ver=1.9.7' id='map_overwrite_default_me-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='media-video-jwt-bridge-js-extra'>
/* <![CDATA[ */
var videopressAjax = {"ajaxUrl":"https:\/\/www.kttn.com\/wp-admin\/admin-ajax.php","bridgeUrl":"https:\/\/www.kttn.com\/wp-content\/plugins\/jetpack\/jetpack_vendor\/automattic\/jetpack-videopress\/src\/..\/build\/lib\/videopress-token-bridge.js","post_id":"263973"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/jetpack/jetpack_vendor/automattic/jetpack-videopress/src/../build/lib/videopress-token-bridge.js?ver=0.8.2' id='media-video-jwt-bridge-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/themes/dw-focus/assets/js/modernizr.min.js?ver=1.4.1' id='modernizr-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/themes/dw-focus/assets/js/jquery-mobile.min.js?ver=1.3.2' id='jquery-mobile-js'></script>
<link rel="https://api.w.org/" href="https://www.kttn.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.kttn.com/wp-json/wp/v2/posts/263973" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kttn.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kttn.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
<link rel='shortlink' href='https://wp.me/p7gMFu-16FD' />
<link rel="alternate" type="application/json+oembed" href="https://www.kttn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.kttn.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&#038;format=xml" />
<meta name="yandex-verification" content="c566ba84af781dbe" />
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-11511473-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'UA-11511473-2');
</script>

<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-2159528617775818"
     crossorigin="anonymous"></script>
<!-- start miniAudioPlayer custom CSS -->

<style id="map_custom_css">
       /* DO NOT REMOVE OR MODIFY */
/*{'skinName': 'mySkin', 'borderRadius': 5, 'main': 'rgb(255, 217, 102)', 'secondary': 'rgb(68, 68, 68)', 'playerPadding': 0}*/
/* END - DO NOT REMOVE OR MODIFY */
/*++++++++++++++++++++++++++++++++++++++++++++++++++
Copyright (c) 2001-2014. Matteo Bicocchi (Pupunzi);
http://pupunzi.com/mb.components/mb.miniAudioPlayer/demo/skinMaker.html

Skin name: mySkin
borderRadius: 5
background: rgb(255, 217, 102)
icons: rgb(68, 68, 68)
border: rgb(55, 55, 55)
borderLeft: rgb(255, 230, 153)
borderRight: rgb(255, 204, 51)
mute: rgba(68, 68, 68, 0.4)
download: rgba(255, 217, 102, 0.4)
downloadHover: rgb(255, 217, 102)
++++++++++++++++++++++++++++++++++++++++++++++++++*/

/* Older browser (IE8) - not supporting rgba() */
.mbMiniPlayer.mySkin .playerTable span{background-color:#ffd966}
.mbMiniPlayer.mySkin .playerTable span.map_play{border-left:1px solid #ffd966;}
.mbMiniPlayer.mySkin .playerTable span.map_volume{border-right:1px solid #ffd966;}
.mbMiniPlayer.mySkin .playerTable span.map_volume.mute{color: #444444;}
.mbMiniPlayer.mySkin .map_download{color: #444444;}
.mbMiniPlayer.mySkin .map_download:hover{color: #444444;}
.mbMiniPlayer.mySkin .playerTable span{color: #444444;}
.mbMiniPlayer.mySkin .playerTable {border: 1px solid #444444 !important;}

/*++++++++++++++++++++++++++++++++++++++++++++++++*/

.mbMiniPlayer.mySkin .playerTable{background-color:transparent; border-radius:5px !important;}
.mbMiniPlayer.mySkin .playerTable span{background-color:rgb(255, 217, 102); padding:3px !important; font-size: 20px;}
.mbMiniPlayer.mySkin .playerTable span.map_time{ font-size: 12px !important; width: 50px !important}
.mbMiniPlayer.mySkin .playerTable span.map_title{ padding:4px !important}
.mbMiniPlayer.mySkin .playerTable span.map_play{border-left:1px solid rgb(255, 204, 51); border-radius:0 4px 4px 0 !important;}
.mbMiniPlayer.mySkin .playerTable span.map_volume{padding-left:6px !important}
.mbMiniPlayer.mySkin .playerTable span.map_volume{border-right:1px solid rgb(255, 230, 153); border-radius:4px 0 0 4px !important;}
.mbMiniPlayer.mySkin .playerTable span.map_volume.mute{color: rgba(68, 68, 68, 0.4);}
.mbMiniPlayer.mySkin .map_download{color: rgba(255, 217, 102, 0.4);}
.mbMiniPlayer.mySkin .map_download:hover{color: rgb(255, 217, 102);}
.mbMiniPlayer.mySkin .playerTable span{color: rgb(68, 68, 68);text-shadow: none!important;}
.mbMiniPlayer.mySkin .playerTable span{color: rgb(68, 68, 68);}
.mbMiniPlayer.mySkin .playerTable {border: 1px solid rgb(55, 55, 55) !important;}
.mbMiniPlayer.mySkin .playerTable span.map_title{color: #000; text-shadow:none!important}
.mbMiniPlayer.mySkin .playerTable .jp-load-bar{background-color:rgba(255, 217, 102, 0.3);}
.mbMiniPlayer.mySkin .playerTable .jp-play-bar{background-color:#ffd966;}
.mbMiniPlayer.mySkin .playerTable span.map_volumeLevel a{background-color:rgb(94, 94, 94); height:80%!important }
.mbMiniPlayer.mySkin .playerTable span.map_volumeLevel a.sel{background-color:#444444;}
.mbMiniPlayer.mySkin  span.map_download{font-size:50px !important;}
/* Wordpress playlist select */
.map_pl_container .pl_item.sel{background-color:#ffd966 !important; color: #444444}
/*++++++++++++++++++++++++++++++++++++++++++++++++*/
       </style>
	
<!-- end miniAudioPlayer custom CSS -->	
	<style>img#wpstats{display:none}</style>
		<style type="text/css">a {color: #2457ee}a:hover, a:active {color: #dc4e32}.site-footer {color: #555555}.site-footer a {color: #777777}.site-footer a:hover, .site-footer a:active {color: #ffffff}.site-footer #footer-widgets .widget-title {color: #ffffff}.site-footer .footer-navigation, #footer-widgets { border-color: #333333}#footer-widgets .widget_nav_menu:after {background-color: #333333}.site-footer {background-color:#000000}body {color:#000000;font-weight:500;font-weight:500;font-size:15px;font-family:Times New Roman;letter-spacing:1;line-height:1.3;}h1, h2, h3, h4, h5, h6, .dw_focus_widget_news_slider .carousel-title-indicators li, .widget_news-slider .carousel-title-indicators li, .post-navigation .nav-links, .dw_focus_widget_news_ticker a, .widget_news-ticker a {font-weight: 400;font-family:Roboto Slab;line-height:1.3;}h1 {font-size:36px}h2 {font-size:30px}h2 {font-size:30px}h3 {font-size:24px}h4 {font-size:18px}h5 {font-size:14px}h6 {font-size:12px}</style><!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-11511473-2"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-11511473-2');
</script>
<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #1e73be; }
</style>
	<link rel="icon" href="https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-110x110.png" sizes="32x32" />
<link rel="icon" href="https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-230x230.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-230x230.png" />
<meta name="msapplication-TileImage" content="https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-360x360.png" />
		<style type="text/css" id="wp-custom-css">
			.tags-links {display:none;}
a:active {color:#00008b!important}

/* unvisited link */
a:link {
  color: blue;
}

/* visited link */
a:visited {
  color: green;
}

/* mouse over link */
a:hover {
  color: red;
}

.wp-caption .wp-caption-text {
text-align: left;
color: #000;
}


.author-info .author-description {font-style: normal; font-size: 20px; color: #000000; } 
.author-info .site-url {font-size: 20px; color: black;}

/* Change style for meta */
.hentry .entry-meta {font-size: 18px; } 

/* Only byline */
.hentry .entry-meta .author a {font-size: 18px; } 

		</style>
		<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-72465590-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->

</head>

<body class="post-template-default single single-post postid-263973 single-format-standard custom-background layout-boxed sidebar-right">
<div id="page" class="hfeed site">
	<header class="site-header">
		<div class="container">
			<div class="row hidden-xs hidden-sm">
				<div class="col-md-4">
																<a href="https://www.kttn.com/" rel="home" class="site-logo"><img src="//www.kttn.com/wp-content/uploads/2022/05/New-KTTN-Logo-V3.png" title="KTTN-FM 92.3 and KGOZ -FM 101.7 "></a>
									</div>
								<div id="header-widgets" class="col-md-8"><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- Horizontal ad for Header -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2159528617775818"
     data-ad-slot="6419972530"
     data-ad-format="auto"></ins>
</div></aside></div>
							</div>
						<div class="navigation-wrap under-navigation-activated">
								<nav id="masthead" class="navbar navbar-default site-navigation" role="banner">
					<div class="navbar-header">
												<button class="navbar-toggle" data-toggle="collapse" data-target=".main-navigation"><i class="fa fa-bars"></i></button>
												<a href="https://www.kttn.com/" rel="home" class="site-brand navbar-brand visible-xs visible-sm">
																						<img src="//www.kttn.com/wp-content/uploads/2022/05/New-KTTN-Logo-V3.png" title="KTTN-FM 92.3 and KGOZ -FM 101.7 ">
													</a>
													<button class="search-toggle visible-xs visible-sm" data-toggle="collapse" data-target=".under-navigation"><i class="fa fa-search"></i></button>
											</div>

					<div id="site-navigation" class="collapse navbar-collapse main-navigation" role="navigation">
						<ul id="menu-main-menu" class="nav navbar-nav navbar-left dw-mega-menu-transition-default"><li class="dw-mega-menu-hover item-243 menu-home"><a href="https://www.kttn.com/">Home</a></li>
<li class="dw-mega-menu-hover item-238575 menu-news color-blue"><a  href="https://www.kttn.com/category/news/">News</a>
<ul class="dw-sub-menu">
	<li class="dw-mega-menu-hover item-238576 menu-local-news"><a  href="https://www.kttn.com/category/news/local/">Local News</a></li>
	<li class="dw-mega-menu-hover item-238577 menu-state-news color-blue"><a  href="https://www.kttn.com/category/news/state/">State News</a></li>
	<li class="dw-mega-menu-hover item-238579 menu-national-news"><a  href="https://www.kttn.com/category/news/national/">National News</a></li>
	<li class="dw-mega-menu-hover item-238578 menu-farm-news"><a  href="https://www.kttn.com/category/news/farmnews/">Farm News</a></li>
</ul>
</li>
<li class="dw-mega-menu-hover item-6739 menu-sports"><a  target="_blank" href="http://www.kttnsports.com">Sports</a></li>
<li class="dw-mega-menu-hover item-2124 menu-weather"><a  target="_blank" href="https://www.kttn.com/weather/">Weather</a></li>
<li class="dw-mega-menu-hover item-10998 menu-contact-kttn"><a  href="https://www.kttn.com/contact-kttnkgoz-radio/">Contact KTTN</a></li>
<li class="dw-mega-menu-hover item-250679 menu-branson-tickets"><a  href="https://www.kttn.com/branson-tickets/">Branson Tickets</a></li>
<li class="current-post-ancestor active current-post-parent dw-mega-menu-hover item-247636 menu-obituaries"><a  href="https://www.kttn.com/category/obits/">Obituaries</a></li>
<li class="dw-mega-menu-hover item-254208 menu-action-auction"></li>
<li class="dw-mega-menu-hover item-169153 menu-kttn-site-search"><a  href="https://www.kttn.com/search/">KTTN Site Search</a></li>
<li class="dw-mega-menu-hover item-221387 menu-other-information"><a  href="https://www.kttn.com/category/otherinfo/">Other Information</a>
<ul class="dw-sub-menu">
	<li class="dw-mega-menu-hover item-259401 menu-birthday-anniversary-call-in-program-rules"><a  href="https://www.kttn.com/birthday-anniversary-call-in-program-rules/">Birthday/Anniversary Call-In Program Rules</a></li>
	<li class="dw-mega-menu-hover item-221391 menu-dmca-policy"><a  href="https://www.kttn.com/dmca-notice/">DMCA Policy</a></li>
	<li class="dw-mega-menu-hover item-221388 menu-media-outlets-using-our-content"><a  href="https://www.kttn.com/media-outlets-use-of-our-content/">Media Outlets: Using Our Content</a></li>
	<li class="dw-mega-menu-hover item-221389 menu-website-disclaimer"><a  href="https://www.kttn.com/website-disclaimer/">Website Disclaimer</a></li>
	<li class="dw-mega-menu-hover item-221390 menu-eeo-reports"><a  href="https://publicfiles.fcc.gov/am-profile/KTTN/equal-employment-opportunity-records">EEO Reports</a></li>
</ul>
</li>
</ul>						<div class="hidden-xs hidden-sm">		<ul class="nav navbar-nav navbar-right">
									<li class="twitter-square">
				<a href="https://www.twitter.com/kttnradio"><i class="fa fa-twitter-square"></i></a>
			</li>
						<li class="youtube">
				<a href="https://www.youtube.com/channel/UCbhAsmtSnFaORuNrNDxehkw"><i class="fa fa-youtube"></i></a>
			</li>
						<li class="facebook-official">
				<a href="https://www.facebook.com/kttnfm"><i class="fa fa-facebook-official"></i></a>
			</li>
									<li class="rss"><a href="https://www.kttn.com/feed/"><i class="fa fa-rss"></i></a></li>					</ul>
	</div>
					</div>
				</nav>

								<div class="under-navigation hidden-xs hidden-sm">
					<div class="row">
						<div class="col-md-9 hidden-xs hidden-sm">		<aside id="news-ticker-2" class="widget dw_focus_widget_news_ticker">		<h2 class="widget-title">Trending Now</h2>		<div class="news-ticker-wrap headlines" data-interval="4000">
			<ul>
							<li>
					<a href="https://www.kttn.com/audio-what-missouri-provides-and-does-not-provide-to-state-prisoners-transitioning-to-the-opposite-sex/">Audio: What Missouri provides, and does not provide, to state prisoners transitioning to the opposite sex</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/hamilton-man-receives-jail-sentence-and-fine/">Hamilton man receives jail sentence and fine</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/cole-county-judge-blocks-effort-to-deny-medicaid-funds-to-planned-parenthood/">Cole County judge blocks effort to deny Medicaid funds to Planned Parenthood</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/meeting-for-group-in-marceline-taking-bus-trip-set-for-january-7-2023/">Meeting for group in Marceline taking bus trip set for January 7, 2023</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/bethany-woman-injured-in-crash-on-highway-136/">Bethany woman injured in crash on Highway 136</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/obituary-susie-doscher/">Obituary: Susie Doscher</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/obituary-mary-etta-dragoo-ireland/">Obituary: Mary Etta (Dragoo) Ireland</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/">Obituary &#038; Services: Clarence Randall Mantzey, Jr</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/bevier-man-dies-in-wednesday-crash-on-highway-63/">Bevier man dies in Wednesday crash on Highway 63</a>
									<span class="post-date">December 29, 2022</span>
								</li>
							<li>
					<a href="https://www.kttn.com/gallatin-board-of-aldermen-announce-results-of-meeting-on-december-27th/">Gallatin Board of Aldermen announce results of meeting on December 27th</a>
									<span class="post-date">December 29, 2022</span>
								</li>
						</ul>
		</div>
		</aside>		</div>
						<div class="col-md-3"><form method="get" id="searchform" action="https://www.kttn.com/">
	<input type="text" name="s" id="s" class="form-control" value="" placeholder="Search">
	<input type="submit" class="search-submit">
</form>
</div>
					</div>
				</div>
							</div>
		</div>
	</header>

	<div id="content" class="site-content">

<div class="container">
	<div class="content-inner">
		<div class="row">
			<div class="col-lg-9">
				<div id="primary" class="content-area">
					<main id="main" class="site-main" role="main">
																	
	<article id="post-263973" class="post-263973 post type-post status-publish format-standard has-post-thumbnail hentry category-obits">
		<header class="entry-header">
			<h1 class="entry-title">Obituary &#038; Services: Clarence Randall Mantzey, Jr</h1>
			<div class="entry-meta">
				<span class="cat-links"><i class="fa fa-folder"></i> <a href="https://www.kttn.com/category/obits/" rel="category tag">Obituaries</a></span><span class="posted-on"><i class="fa fa-clock-o"></i> <a href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" rel="bookmark"><span class="entry-date published">December 29, 2022</span><span class="updated sr-only">December 29, 2022</span></a></span><span class="byline"> <i class="fa fa-user"></i> <span class="author vcard"><a class="url fn" href="https://www.kttn.com/author/kttn-news/">KTTN News</a></span></span>			</div>
		</header>

				<div class="entry-thumbnail"><img width="770" height="440" src="https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Clarence Randall Mantzey obit photo" decoding="async" srcset="https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo.jpg 770w, https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo-228x130.jpg 228w, https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo-500x286.jpg 500w, https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo-110x63.jpg 110w, https://www.kttn.com/wp-content/uploads/2022/12/Clarence-Randall-Mantzey-obit-photo-230x131.jpg 230w" sizes="(max-width: 770px) 100vw, 770px" /></div>
	
	<div class="row">
		<div class="entry-content col-md-9 col-md-push-3">
			<div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_light_gray_outlines swp_individual_color_outlines scale-100 scale-full_width" data-min-width="500" data-float-color="#ffffff" data-float="left" data-float-mobile="bottom" data-transition="slide" data-post-id="263973" ><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_tumblr" data-network="tumblr"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&title=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr" data-link="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&title=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_tumblr_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_parler" data-network="parler"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://parler.com/new-post?message=Obituary &#038; Services: Clarence Randall Mantzey, Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://parler.com/new-post?message=Obituary &#038; Services: Clarence Randall Mantzey, Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_parler_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&via=KTTNRadio" data-link="https://twitter.com/intent/tweet?text=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&via=KTTNRadio"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
							e.setAttribute('type','text/javascript');
							e.setAttribute('charset','UTF-8');
							e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
							document.body.appendChild(e);
						" ><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt" ><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div></div><p><span style="font-size: 14pt;">Clarence Randall Mantzey, Jr., a resident of Chillicothe, Missouri, passed away Sunday, December 25, 2022, at his residence.</span></p>
<p><span style="font-size: 14pt;">Clarence was born the son of Clarence Randall &ldquo;Red&rdquo; and Mildred (Williams) Mantzey on October 16, 1950, in Chillicothe, Missouri. Clarence was a 1968 graduate of Tina-Avalon High School. He proudly served in the United States Navy and retired from the United States Army with the rank of Master Sergeant. He considered being in the Veterans of Foreign Wars quite an honor. He was also a long-standing member of the Eagles Club. </span><span style="font-size: 14pt;">He married Diann Daley on May 5, 2007 She preceded him in death in September of 2022.</span></p>
<p><span style="font-size: 14pt;">Survivors include one son, Clarence Randall Mantzey, III, and his wife, Alessandra, of San Antonio, Texas; one daughter, Cassandra (Mantzey) Rounkles and husband, Michael Joe, of Corder, Missouri; six grandchildren, three great-grandchildren, five step-grandchildren, six step-great-grandchildren, two sisters, Alice Gates, and husband, Dave, of Chillicothe, Missouri and Wanda Treon of Mooresville, Missouri; and several friends and family. He was preceded in death by his parents; his second wife; one son, Nathaniel Mantzey; one brother, and one sister.</span></p>
<p><span style="font-size: 14pt;">Funeral services will be held at the Lindley Funeral Home, Tina, Missouri, on January 6, 2023, at 2:00 p.m. A scheduled visitation will be held at the Lindley Funeral Home, Tina, Missouri, at 1:00 p.m., one hour before the service. Burial will follow at New Salem Cemetery, Tina, Missouri. Friends may call at the Lindley Funeral Home, Tina, Missouri, Thursday, January 5, 2023, from 12:00 noon until 5:00 p.m. Memorial contributions may be made to the Veterans of Foreign Wars and may be mailed to or left at Lindley Funeral Home, PO Box 47, Chillicothe, Missouri, 64601.&nbsp;</span></p>
<div class="post-views content-post post-263973 entry-meta">
				<span class="post-views-icon dashicons dashicons-chart-bar"></span> <span class="post-views-label">Post Views:</span> <span class="post-views-count">94</span>
			</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" data-text="Obituary &amp; Services: Clarence Randall Mantzey, Jr" data-via="KTTNRadio" >Tweet</a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button" href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp" ><span>WhatsApp</span></a></li><li class="share-linkedin"><div class="linkedin_button"><script type="in/share" data-url="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" data-counter="right"></script></div></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button" href="/cdn-cgi/l/email-protection#ab94d8dec9c1cec8df968e9ee9f8c3cad9cecf8e999bfbc4d8df8e9eef8e999be4c9c2dfdecad9d28e999b8e999d8e999bf8ced9ddc2c8ced88e98ea8e999be8c7cad9cec5c8ce8e999bf9cac5cfcac7c78e999be6cac5dfd1ced28e99e88e999be1d98dc9c4cfd296c3dfdfdbd88e98ea8e99ed8e99eddcdcdc85c0dfdfc585c8c4c68e99eddd9986c4c9c2dfdecad9d286d8ced9ddc2c8ced886c8c7cad9cec5c8ce86d9cac5cfcac7c786c6cac5dfd1ced286c1d98e99ed8dd8c3cad9ce96cec6cac2c7" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="0983228dde" data-email-share-track-url="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/?share=email"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button" href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/#print" target="_blank" title="Click to print" ><span>Print</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a class="tumblr-share-button" target="_blank" href="https://www.tumblr.com/share" data-title="Obituary & Services: Clarence Randall Mantzey, Jr" data-content="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" title="Share on Tumblr">Share on Tumblr</a></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&#038;media=https%3A%2F%2Fwww.kttn.com%2Fwp-content%2Fuploads%2F2022%2F12%2FClarence-Randall-Mantzey-obit-photo.jpg&#038;description=Obituary%20%26%20Services%3A%20Clarence%20Randall%20Mantzey%2C%20Jr" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-end"></li><li class="share-reddit"><div class="reddit_button"><iframe src="https://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&amp;title=Obituary%20%26%20Services%3A%20Clarence%20Randall%20Mantzey%2C%20Jr" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-pocket"><div class="pocket_button"><a href="https://getpocket.com/save" class="pocket-btn" data-lang="en" data-save-url="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" data-pocket-count="horizontal" >Pocket</a></div></li><li class="share-end"></li><li class="share-telegram"><a rel="nofollow noopener noreferrer" data-shared="" class="share-telegram sd-button" href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/?share=telegram" target="_blank" title="Click to share on Telegram" ><span>Telegram</span></a></li><li class="share-skype"><div class="skype-share" data-href="https://www.kttn.com/v2-obituary-services-clarence-randall-mantzey-jr/" data-lang="en-US" data-style="small" data-source="jetpack" ></div></li><li class="share-end"></li><li class="share-end"></li></ul></div></div></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><div class="swp_social_panel swp_horizontal_panel swp_flat_fresh  swp_default_full_color swp_other_light_gray_outlines swp_individual_color_outlines scale-100 scale-full_width" data-min-width="500" data-float-color="#ffffff" data-float="left" data-float-mobile="bottom" data-transition="slide" data-post-id="263973" ><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_tumblr" data-network="tumblr"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&title=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr" data-link="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&title=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_tumblr_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_parler" data-network="parler"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://parler.com/new-post?message=Obituary &#038; Services: Clarence Randall Mantzey, Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://parler.com/new-post?message=Obituary &#038; Services: Clarence Randall Mantzey, Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_parler_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&via=KTTNRadio" data-link="https://twitter.com/intent/tweet?text=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&via=KTTNRadio"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
							e.setAttribute('type','text/javascript');
							e.setAttribute('charset','UTF-8');
							e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
							document.body.appendChild(e);
						" ><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt" ><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div></div>						</div>
			<div class="entry-sidebar col-md-3 col-md-pull-9">
						<div class="entry-sharing">
			<h3>Sharing</h3>
			<ul class="dw-social-share dwss-style-7"><li class="dwss-facebook"><a href="javascript.void(0);" rel="nofollow"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li><li class="dwss-twitter"><a href="javascript.void(0);" rel="nofollow"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li><li class="dwss-linkedin"><a href="javascript.void(0);" rel="nofollow"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li><li class="dwss-pinterest"><a href="javascript.void(0);" rel="nofollow"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li><li class="dwss-mail" ><a href="/cdn-cgi/l/email-protection#f697929b9f98b6938e979b869a93d895999bc9a583949c939582cbb9949f828397848fd3c4c6d3c4c0d3c4c5c6c5ced3c5b4d3c4c6a59384809f959385d3c5b7d3c4c6b59a978493989593d3c4c6a4979892979a9ad3c4c6bb9798828c938fd3c4b5d3c4c6bc84" rel="nofollow"><i class="fa fa-envelope-o"></i> <span>Email</span></a></li><li class="dwss-print" ><a href="javascript.void(0);" rel="nofollow"><i class="fa fa-print"></i> <span>Print</span></a></li></ul>		</div>
						</div>
		</div>

	</article>
												
	<nav class="navigation post-navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.kttn.com/bevier-man-dies-in-wednesday-crash-on-highway-63/" rel="prev">Bevier man dies in Wednesday crash on Highway 63</a></div><div class="nav-next"><a href="https://www.kttn.com/obituary-mary-etta-dragoo-ireland/" rel="next">Obituary: Mary Etta (Dragoo) Ireland</a></div></div>
	</nav>						<div class="author-info">
							<div class="author-avatar">
								<img src="https://www.kttn.com/wp-content/uploads/2016/11/1619139_601778026557647_1788299978_n-110x110.png" width="72" height="72" alt="Avatar" class="avatar avatar-72 wp-user-avatar wp-user-avatar-72 photo avatar-default" />							</div>
							<div class="author-detail">
								<h4 class="author-title"> <a href="https://www.kttn.com/author/kttn-news/" title="Posts by KTTN News" rel="author">KTTN News</a></h4>
								<p class="site-url"><a href="https://www.kttn.com">http://www.kttn.com</a>
								</p>
								<p class="author-description"></p>
								<ul class="author-icons">
																	</ul>

							</div>
						</div>					
						<!-- Related post -->
																			<!-- Related Posts  -->
														<!-- End Related post -->		
												<!-- End Related post -->
						
<section id="comments" class="comments">
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/v2-obituary-services-clarence-randall-mantzey-jr/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://www.kttn.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</section>
										</main>
				</div>
			</div>
			<div class="col-lg-3">
				
<div id="secondary" class="widget-area" role="complementary">
	<aside id="custom_html-2" class="widget_text widget widget_custom_html"><h2 class="widget-title">Listen To KTTN Live</h2><div class="textwidget custom-html-widget"><a href="https://onlineradiobox.com/us/kttn923fm/" title="Listen on Online Radio Box!" target="_blank" rel="noopener"><img src="https://www.kttn.com/wp-content/uploads/2020/07/KTTNbutton.jpg" alt="Listen on Online Radio Box!" style="width: 240px; height: 84px;"/></a></div></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html"><h2 class="widget-title">Listen to KGOZ Live</h2><div class="textwidget custom-html-widget"><a href="https://onlineradiobox.com/us/kgoz/" title="Listen on Online Radio Box!" target="_blank" rel="noopener"><img src="https://www.kttn.com/wp-content/uploads/2020/07/Z1017-Play-Button.jpg" alt="Listen on Online Radio Box!" style="width: 240px; height: 84px;"/></a></div></aside><aside id="facebook-likebox-7" class="widget widget_facebook_likebox"><h2 class="widget-title"><a href="https://www.facebook.com/kttnfm/">Like Us on Facebook</a></h2>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/kttnfm/" data-width="340"  data-height="130" data-hide-cover="false" data-show-facepile="false" data-tabs="false" data-hide-cta="false" data-small-header="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/kttnfm/"><a href="https://www.facebook.com/kttnfm/">Like Us on Facebook</a></blockquote></div>
		</div>
		</aside><aside id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- kttn sports all ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2159528617775818"
     data-ad-slot="7104297081"
     data-ad-format="auto"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"
    crossorigin="anonymous"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="top-posts-10" class="widget widget_top-posts"><h2 class="widget-title">Most Popular articles</h2><ul class='widgets-list-layout no-grav'>
<li><a href="https://www.kttn.com/missouri-state-highway-patrol-reports-three-traffic-fatalities-over-christmas-hholiday-weekend/" title="Missouri State Highway Patrol reports three traffic fatalities over Christmas hHoliday weekend" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2020/11/Missouri-State-Highway-Patrol-Website-New-2021.jpg?resize=40%2C40&#038;ssl=1" alt="Missouri State Highway Patrol reports three traffic fatalities over Christmas hHoliday weekend" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/missouri-state-highway-patrol-reports-three-traffic-fatalities-over-christmas-hholiday-weekend/" title="Missouri State Highway Patrol reports three traffic fatalities over Christmas hHoliday weekend" class="bump-view" data-bump-view="tp">Missouri State Highway Patrol reports three traffic fatalities over Christmas hHoliday weekend</a>
							</div>
							</li><li><a href="https://www.kttn.com/woman-stopped-with-with-small-child-holding-a-bag-of-fentanyl-receives-25-year-prison-sentence/" title="Woman stopped with with small child holding a bag of fentanyl receives 25 year prison sentence" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2020/12/Fentanyl-Graphic.jpg?resize=40%2C40&#038;ssl=1" alt="Woman stopped with with small child holding a bag of fentanyl receives 25 year prison sentence" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/woman-stopped-with-with-small-child-holding-a-bag-of-fentanyl-receives-25-year-prison-sentence/" title="Woman stopped with with small child holding a bag of fentanyl receives 25 year prison sentence" class="bump-view" data-bump-view="tp">Woman stopped with with small child holding a bag of fentanyl receives 25 year prison sentence</a>
							</div>
							</li><li><a href="https://www.kttn.com/man-from-missouri-pleads-guilty-to-heroin-trafficking-faces-up-to-40-years-in-prison/" title="Man from Missouri pleads guilty to heroin trafficking, faces up to 40 years in prison" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2016/12/Heroin.jpg?resize=40%2C40&#038;ssl=1" alt="Man from Missouri pleads guilty to heroin trafficking, faces up to 40 years in prison" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/man-from-missouri-pleads-guilty-to-heroin-trafficking-faces-up-to-40-years-in-prison/" title="Man from Missouri pleads guilty to heroin trafficking, faces up to 40 years in prison" class="bump-view" data-bump-view="tp">Man from Missouri pleads guilty to heroin trafficking, faces up to 40 years in prison</a>
							</div>
							</li><li><a href="https://www.kttn.com/obituary-mary-etta-dragoo-ireland/" title="Obituary: Mary Etta (Dragoo) Ireland" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2022/12/Mary-Ireland-Obit-Photo.jpg?resize=40%2C40&#038;ssl=1" alt="Obituary: Mary Etta (Dragoo) Ireland" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/obituary-mary-etta-dragoo-ireland/" title="Obituary: Mary Etta (Dragoo) Ireland" class="bump-view" data-bump-view="tp">Obituary: Mary Etta (Dragoo) Ireland</a>
							</div>
							</li><li><a href="https://www.kttn.com/minimum-wage-to-increase-in-january-2023/" title="Minimum wage to increase in January 2023" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2021/02/Minimum-Wage.jpg?resize=40%2C40&#038;ssl=1" alt="Minimum wage to increase in January 2023" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/minimum-wage-to-increase-in-january-2023/" title="Minimum wage to increase in January 2023" class="bump-view" data-bump-view="tp">Minimum wage to increase in January 2023</a>
							</div>
							</li><li><a href="https://www.kttn.com/600-notices-for-jury-duty-go-out-to-livingston-county-residents/" title="600 notices for jury duty go out to Livingston County residents" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2019/09/Jury-Duty.jpg?resize=40%2C40&#038;ssl=1" alt="600 notices for jury duty go out to Livingston County residents" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/600-notices-for-jury-duty-go-out-to-livingston-county-residents/" title="600 notices for jury duty go out to Livingston County residents" class="bump-view" data-bump-view="tp">600 notices for jury duty go out to Livingston County residents</a>
							</div>
							</li><li><a href="https://www.kttn.com/hamilton-man-receives-jail-sentence-and-fine/" title="Hamilton man receives jail sentence and fine" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2016/12/Court-News.jpg?resize=40%2C40&#038;ssl=1" alt="Hamilton man receives jail sentence and fine" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/hamilton-man-receives-jail-sentence-and-fine/" title="Hamilton man receives jail sentence and fine" class="bump-view" data-bump-view="tp">Hamilton man receives jail sentence and fine</a>
							</div>
							</li><li><a href="https://www.kttn.com/two-candidates-join-the-race-for-trenton-r-9-board-of-education/" title="Two candidates join the race for Trenton R-9 Board of Education" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2017/04/Trenton-R-9-School-District.jpg?resize=40%2C40&#038;ssl=1" alt="Two candidates join the race for Trenton R-9 Board of Education" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/two-candidates-join-the-race-for-trenton-r-9-board-of-education/" title="Two candidates join the race for Trenton R-9 Board of Education" class="bump-view" data-bump-view="tp">Two candidates join the race for Trenton R-9 Board of Education</a>
							</div>
							</li><li><a href="https://www.kttn.com/owner-of-rockstar-burgers-pleads-guilty-to-making-restaurant-available-to-drug-traffickers-in-1-7-million-conspiracy/" title="Owner of Rockstar Burgers pleads guilty to making restaurant available to drug traffickers in $1.7 million conspiracy" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2022/12/Rockstar-Burgers-News-Photo.jpg?resize=40%2C40&#038;ssl=1" alt="Owner of Rockstar Burgers pleads guilty to making restaurant available to drug traffickers in $1.7 million conspiracy" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/owner-of-rockstar-burgers-pleads-guilty-to-making-restaurant-available-to-drug-traffickers-in-1-7-million-conspiracy/" title="Owner of Rockstar Burgers pleads guilty to making restaurant available to drug traffickers in $1.7 million conspiracy" class="bump-view" data-bump-view="tp">Owner of Rockstar Burgers pleads guilty to making restaurant available to drug traffickers in $1.7 million conspiracy</a>
							</div>
							</li><li><a href="https://www.kttn.com/two-injured-including-10-year-old-boy-in-crash-on-i-35/" title="Two injured, including 10-year-old boy, in crash on I-35" class="bump-view" data-bump-view="tp"><img width="40" height="40" src="https://i0.wp.com/www.kttn.com/wp-content/uploads/2018/12/Accident-Crash-4.jpg?resize=40%2C40&#038;ssl=1" alt="Two injured, including 10-year-old boy, in crash on I-35" data-pin-nopin="true" class="widgets-list-layout-blavatar" /></a><div class="widgets-list-layout-links">
								<a href="https://www.kttn.com/two-injured-including-10-year-old-boy-in-crash-on-i-35/" title="Two injured, including 10-year-old boy, in crash on I-35" class="bump-view" data-bump-view="tp">Two injured, including 10-year-old boy, in crash on I-35</a>
							</div>
							</li></ul>
</aside><aside id="custom_html-6" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- kttn sports all ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2159528617775818"
     data-ad-slot="7104297081"
     data-ad-format="auto"></ins>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"
    crossorigin="anonymous"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside><aside id="rss-3" class="widget widget_rss"><h2 class="widget-title"><a class="rsswidget rss-widget-feed" href="http://www.npr.org/rss/rss.php?id=1001"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.kttn.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.npr.org/templates/story/story.php?storyId=1001">NPR Top Headlines</a></h2><ul><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145997677/doj-amerisourcebergen-alleged-opioid-violations'>Feds sue AmerisourceBergen over &#039;hundreds of thousands&#039; of alleged opioid violations</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145997483/benedict-xvi-health-vatican'>The Vatican says Benedict XVI is lucid and stable, but his condition is &#039;serious&#039;</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145967684/winter-storm-buffalo-death-toll-driving-ban-lifted'>A nearly week-long driving ban is lifted in Buffalo as temperatures rise</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145969469/baby-pygmy-hippo-richmond-metro-zoo'>This zoo didn&#039;t just get a hippopotamus for Christmas — it got a baby pygmy one</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145882657/buffalos-snowbound-residents-turn-to-a-facebook-group-for-help-from-their-neighb'>Buffalo&#039;s snowbound residents turn to a Facebook group for help from their neighbors</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145969191/a-massive-fire-at-cambodia-hotel-and-casino-kills-at-least-19-people'>A massive fire at Cambodia hotel and casino kills at least 19 people</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145954693/russia-launches-new-waves-of-missiles-into-ukraine'>Russia launches a new wave of missiles into Ukraine</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145082842/france-ukraine-kharkiv-migrants-employment'>At a French factory, the newest employees come from Ukraine</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145776865/burna-boy-damini-record-nigeria-music-album'>The Burna Boy philosophy: &#039;Anybody not comfortable with my reality is not my fan&#039;</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145846556/unclaimed-luggage-flight-cancellations-winter-storm-southwest'>Unclaimed luggage piles up at airports following Southwest cancellations</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145499746/retirement-savings-401k-government-help'>Big changes to retirement savings in new federal spending bill</a></li><li><a class='rsswidget' href='https://www.npr.org/sections/health-shots/2022/12/29/1143823727/bleeding-and-in-pain-she-couldnt-get-2-louisiana-ers-to-answer-is-it-a-miscarria'>Bleeding and in pain, she couldn&#039;t get 2 Louisiana ERs to answer: Is it a miscarriage?</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145297807/crypto-crash-ftx-cryptocurrency-bitcoin'>2022 was the year crypto came crashing down to Earth</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1139782011/to-peer-into-earths-deep-time-meet-a-hardy-mineral-known-as-the-time-lord'>To peer into Earth&#039;s deep time, meet a hardy mineral known as the Time Lord</a></li><li><a class='rsswidget' href='https://www.npr.org/2022/12/29/1145952664/benjamin-netanyahus-new-israeli-government-will-make-west-bank-expansion-a-prior'>Benjamin Netanyahu&#039;s new Israeli government will make West Bank expansion a priority</a></li></ul></aside><aside id="rss-2" class="widget widget_rss"><h2 class="widget-title"><a class="rsswidget rss-widget-feed" href="https://www.yahoo.com/news/rss/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.kttn.com/wp-includes/images/rss.png" alt="RSS" loading="lazy" /></a> <a class="rsswidget rss-widget-title" href="https://www.yahoo.com/news">Yahoo News</a></h2><ul><li><a class='rsswidget' href='https://news.yahoo.com/jan-6-transcripts-guilfoyle-demands-213424272.html'>Jan. 6 transcripts: Guilfoyle demands $60k, White House chief burns docs, white nationalist pleads 5th</a></li><li><a class='rsswidget' href='https://news.yahoo.com/think-those-bags-recyclable-california-175113980.html'>Think those bags are recyclable? California says think again</a></li><li><a class='rsswidget' href='https://news.yahoo.com/ate-oldest-operating-restaurant-planet-130100284.html'>I ate at the oldest operating restaurant on the planet to see if it&#039;s a tourist trap or worth the hype</a></li><li><a class='rsswidget' href='https://news.yahoo.com/67-old-ugandan-man-102-170951339.html'>67-Year-Old Ugandan Man Who Has 102 Children And 568 Grandchildren Says This Is Why He&#039;s Done Having Kids</a></li><li><a class='rsswidget' href='https://news.yahoo.com/sea-monsters-were-real-millions-160556009.html'>&#039;Sea monsters&#039; were real millions of years ago. New fossils tell about their rise and fall</a></li><li><a class='rsswidget' href='https://news.yahoo.com/kanye-west-reportedly-nowhere-found-153000244.html'>Kanye West reportedly nowhere to be found as ex-business manager tries to serve him</a></li><li><a class='rsswidget' href='https://news.yahoo.com/least-19-killed-casino-fire-143508571.html'>At least 19 killed in casino fire as victims jump from ledge</a></li><li><a class='rsswidget' href='https://news.yahoo.com/man-given-death-penalty-footage-141257975.html'>A man was given the death penalty after footage of him being roasted in jail by Comedy Central&#039;s Jeff Ross was used in his sentencing</a></li><li><a class='rsswidget' href='https://news.yahoo.com/tiktoker-says-she-pretends-her-124932576.html'>A TikToker says she pretends to be her identical twin every holiday for her grandparents who don&#039;t know she died</a></li><li><a class='rsswidget' href='https://news.yahoo.com/teen-sold-sex-slavery-facebook-093514144.html'>Teen Sold into Sex Slavery After Facebook Did Nothing for 24 Hours</a></li><li><a class='rsswidget' href='https://news.yahoo.com/fallen-colossus-ussrs-terror-triumphs-081249121.html'>Fallen colossus: USSR&#039;s terror, triumphs began 100 years ago</a></li><li><a class='rsswidget' href='https://news.yahoo.com/kiffin-texas-tech-player-spit-080835640.html'>Kiffin: Texas Tech player spit, possibly used racial slur</a></li><li><a class='rsswidget' href='https://news.yahoo.com/sarajevo-agony-echoes-ukraine-braces-050926178.html'>Sarajevo’s agony echoes as Ukraine braces for a dark winter</a></li><li><a class='rsswidget' href='https://news.yahoo.com/court-unveil-recount-results-3-050357656.html'>Democrat wins Arizona attorney general race after recount</a></li><li><a class='rsswidget' href='https://news.yahoo.com/buffalo-woman-found-stranger-crying-095248931.html'>A Buffalo woman found a stranger crying for help in the blizzard with a tote bag frozen to his hands. She scrapped her Christmas plans to care for him.</a></li><li><a class='rsswidget' href='https://news.yahoo.com/northern-california-statue-meat-packing-014546747.html'>Northern California statue of meat-packing magnate beheaded</a></li><li><a class='rsswidget' href='https://news.yahoo.com/marjorie-taylor-greene-rages-tulsi-005002242.html'>Marjorie Taylor Greene Rages At Tulsi Gabbard For Not Going Easy On George Santos</a></li><li><a class='rsswidget' href='https://news.yahoo.com/santos-scandal-crashes-mccarthy-speakership-225352874.html'>Santos scandal crashes into McCarthy speakership battle</a></li><li><a class='rsswidget' href='https://news.yahoo.com/desantis-administration-launches-investigation-holiday-220348329.html'>DeSantis administration launches investigation into holiday drag show</a></li><li><a class='rsswidget' href='https://news.yahoo.com/neymar-sent-off-psg-dive-220238320.html'>Neymar sent off for PSG after dive in 1st game since WCup</a></li></ul></aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- kttn sports all ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-2159528617775818"
     data-ad-slot="7104297081"
     data-ad-format="auto"></ins>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"
    crossorigin="anonymous"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div></aside></div>
			</div>
		</div>
	</div>
</div>

	</div>

	<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="container">
			<div class="footer-navigation"><div class="breadcrumbs"><span><span><a href="https://www.kttn.com/"><i class="fa fa-home"></i> Home</a></span> <i class="fa fa-caret-right"></i> <span><a href="https://www.kttn.com/category/obits/">Obituaries</a></span> <i class="fa fa-caret-right"></i> <span class="breadcrumb_last" aria-current="page">Obituary &#038; Services: Clarence Randall Mantzey, Jr</span></span></div></div>			<div class="row">
				<div class="site-info col-md-6">
					Copyright &copy; 2022 by <a href="https://www.kttn.com">KTTN-FM 92.3 and KGOZ -FM 101.7 </a>.					Theme: <a href="http://www.designwall.com/wordpress/themes/dw-focus/" title="WordPress News Theme">DW Focus</a> by <a href="http://www.designwall.com/" rel="designer">DesignWall</a>.<br>
					<a href="https://wordpress.org/">Proudly powered by WordPress</a>
				</div>
												<div class="site-footer-logo col-md-6 text-right">
					<a href="https://www.kttn.com/" rel="home"><img src="//www.kttn.com/wp-content/uploads/2016/02/picture-1-1455748174.png" title="KTTN-FM 92.3 and KGOZ -FM 101.7 "></a>
				</div>
							</div>
		</div>
	</footer>
</div>
<script>
(function($) {
    $(document).ready(function () {
        var elem = $(".news-ticker-wrap a");
        if (elem) {
            elem.keydown(function () {
                if (elem.val().length > 10)
                    elem.val(elem.val().substr(0, 10));
            });
        }
    });
})(jQuery);
</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" crossorigin="anonymous"></script>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '120662631643754',
      xfbml      : true,
      version    : 'v3.1'
    });
    FB.AppEvents.logPageView();
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "https://connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.kttn.com\/v2-obituary-services-clarence-randall-mantzey-jr\/":263973};
	</script>
							<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			document.body.addEventListener( 'is.post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
						<script type="text/javascript">
				( function () {
					var currentScript = document.currentScript;

					// Helper function to load an external script.
					function loadScript( url, cb ) {
						var script = document.createElement( 'script' );
						var prev = currentScript || document.getElementsByTagName( 'script' )[ 0 ];
						script.setAttribute( 'async', true );
						script.setAttribute( 'src', url );
						prev.parentNode.insertBefore( script, prev );
						script.addEventListener( 'load', cb );
					}

					function init() {
						loadScript( 'https://platform.linkedin.com/in.js?async=true', function () {
							if ( typeof IN !== 'undefined' ) {
								IN.init();
							}
						} );
					}

					if ( document.readyState === 'loading' ) {
						document.addEventListener( 'DOMContentLoaded', init );
					} else {
						init();
					}

					document.body.addEventListener( 'is.post-load', function() {
						if ( typeof IN !== 'undefined' ) {
							IN.parse();
						}
					} );
				} )();
			</script>
						<script id="tumblr-js" type="text/javascript" src="https://assets.tumblr.com/share-button.js"></script>
								<script type="text/javascript">
				( function () {
					// Pinterest shared resources
					var s = document.createElement( 'script' );
					s.type = 'text/javascript';
					s.async = true;
					s.setAttribute( 'data-pin-hover', true );					s.src = window.location.protocol + '//assets.pinterest.com/js/pinit.js';
					var x = document.getElementsByTagName( 'script' )[ 0 ];
					x.parentNode.insertBefore(s, x);
					// if 'Pin it' button has 'counts' make container wider
					function init() {
						var shares = document.querySelectorAll( 'li.share-pinterest' );
						for ( var i = 0; i < shares.length; i++ ) {
							var share = shares[ i ];
							if ( share.querySelector( 'a span:visible' ) ) {
								share.style.width = '80px';
							}
						}
					}

					if ( document.readyState !== 'complete' ) {
						document.addEventListener( 'load', init );
					} else {
						init();
					}
				} )();
			</script>
				<script>
		( function () {
			var currentScript = document.currentScript;

			// Don't use Pocket's default JS as it we need to force init new Pocket share buttons loaded via JS.
			function jetpack_sharing_pocket_init() {
				var script = document.createElement( 'script' );
				var prev = currentScript || document.getElementsByTagName( 'script' )[ 0 ];
				script.setAttribute( 'async', true );
				script.setAttribute( 'src', 'https://widgets.getpocket.com/v1/j/btn.js?v=1' );
				prev.parentNode.insertBefore( script, prev );
			}

			if ( document.readyState === 'loading' ) {
				document.addEventListener( 'DOMContentLoaded', jetpack_sharing_pocket_init );
			} else {
				jetpack_sharing_pocket_init();
			}
			document.body.addEventListener( 'is.post-load', jetpack_sharing_pocket_init );
		} )();
		</script>
						<script>
				(function(r, d, s) {
					r.loadSkypeWebSdkAsync = r.loadSkypeWebSdkAsync || function(p) {
							var js, sjs = d.getElementsByTagName(s)[0];
							if (d.getElementById(p.id)) { return; }
							js = d.createElement(s);
							js.id = p.id;
							js.src = p.scriptToLoad;
							js.onload = p.callback
							sjs.parentNode.insertBefore(js, sjs);
						};
					var p = {
						scriptToLoad: 'https://swx.cdn.skype.com/shared/v/latest/skypewebsdk.js',
						id: 'skype_web_sdk'
					};
					r.loadSkypeWebSdkAsync(p);
				})(window, document, 'script');
			</script>
			<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/dw-megamenu/assets/js/dw-megamenu.js?ver=6.1.1' id='dw-megamenu-front-end-js-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/dw-social-share/assets/js/script.js?ver=1.0.0' id='dw-social-share-js'></script>
<script type='text/javascript' id='post-views-counter-frontend-js-extra'>
/* <![CDATA[ */
var pvcArgsFrontend = {"mode":"js","postID":"263973","requestURL":"https:\/\/www.kttn.com\/wp-admin\/admin-ajax.php","nonce":"71a77591e8"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/post-views-counter/js/frontend.min.js?ver=1.3.12' id='post-views-counter-frontend-js'></script>
<script type='text/javascript' id='social_warfare_script-js-extra'>
/* <![CDATA[ */
var socialWarfare = {"addons":["pro"],"post_id":"263973","variables":{"emphasizeIcons":"0","powered_by_toggle":false,"affiliate_link":"https:\/\/warfareplugins.com"},"floatBeforeContent":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/social-warfare/assets/js/script.min.js?ver=4.3.0' id='social_warfare_script-js'></script>
<script type='text/javascript' src='https://www.kttn.com/wp-includes/js/comment-reply.min.js?ver=6.1.1' id='comment-reply-js'></script>
<script type='text/javascript' id='dw-focus-script-js-extra'>
/* <![CDATA[ */
var dw_focus = {"ajax_url":"https:\/\/www.kttn.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/themes/dw-focus/assets/js/dw-focus.min.js?ver=1.4.1' id='dw-focus-script-js'></script>
<script type='text/javascript' id='jetpack-facebook-embed-js-extra'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js?ver=11.6' id='jetpack-facebook-embed-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.kttn.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=11.6' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-telegram' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-telegram' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
						return false;
					}
				} );
			} )();
</script>

	<!-- start miniAudioPlayer initializer -->
	<script type="text/javascript">

	let isGutenberg = true;
	let miniAudioPlayer_replaceDefault = 1;
	let miniAudioPlayer_excluded = "map_excluded";
	let miniAudioPlayer_replaceDefault_show_title = 1;

	let miniAudioPlayer_defaults = {
				inLine:true,
                width:"90%",
				skin:"blue",
				animate:false,
				volume:.8,
				autoplay:false,
				showVolumeLevel:true,
				allowMute: true,
				showTime:true,
				id3:true,
				showRew:true,
				addShadow: false,
				downloadable:false,
				downloadPage: null,
				swfPath:"https://www.kttn.com/wp-content/plugins/wp-miniaudioplayer/js/",
				onReady: function(player, $controlsBox){
				   if(player.opt.downloadable && player.opt.downloadablesecurity && !false){
				        jQuery(".map_download", $controlsBox).remove();
				   }
				}
		};

    function initializeMiniAudioPlayer(){
         jQuery(".mejs-container a").addClass(miniAudioPlayer_excluded);
         jQuery("a[href *= '.mp3']").not(".map_excluded").not(".wp-playlist-caption").not("[download]").mb_miniPlayer(miniAudioPlayer_defaults);
    }

    //if(1)
        jQuery("body").addClass("map_replaceDefault");

	jQuery(function(){
     // if(1)
         setTimeout(function(){replaceDefault();},10);
      
      initializeMiniAudioPlayer();
      jQuery(document).ajaxSuccess(function(event, xhr, settings) {
        initializeMiniAudioPlayer();
      });
	});
	</script>
	<!-- end miniAudioPlayer initializer -->

	<div class="swp_social_panelSide swp_floating_panel swp_social_panel swp_circles swp_default_full_color swp_other_light_gray_outlines swp_individual_color_outlines slide swp_float_left swp_side_center scale-100 float-position-center-left" data-min-width="500" data-float-color="#ffffff" data-float="left" data-float-mobile="bottom" data-transition="slide" data-post-id="263973" ><div class="nc_tweetContainer swp_share_button total_shares total_sharesalt" ><span class="swp_count ">0 <span class="swp_label">Shares</span></span></div><div class="nc_tweetContainer swp_share_button swp_whatsapp" data-network="whatsapp"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_whatsapp_icon"></i><span class="swp_share">WhatsApp</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_tumblr" data-network="tumblr"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&title=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr" data-link="https://www.tumblr.com/widgets/share/tool?posttype=link&canonicalUrl=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&title=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_tumblr_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_reddit" data-network="reddit"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_reddit_icon"></i><span class="swp_share">Reddit</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_parler" data-network="parler"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://parler.com/new-post?message=Obituary &#038; Services: Clarence Randall Mantzey, Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://parler.com/new-post?message=Obituary &#038; Services: Clarence Randall Mantzey, Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_parler_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_facebook" data-network="facebook"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.facebook.com/share.php?u=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_facebook_icon"></i><span class="swp_share">Share</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_twitter" data-network="twitter"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://twitter.com/intent/tweet?text=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&via=KTTNRadio" data-link="https://twitter.com/intent/tweet?text=Obituary+%26+Services%3A+Clarence+Randall+Mantzey%2C+Jr&url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F&via=KTTNRadio"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_twitter_icon"></i><span class="swp_share">Tweet</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_pinterest" data-network="pinterest"><a rel="nofollow noreferrer noopener" class="nc_tweet swp_share_link noPop" onClick="var e=document.createElement('script');
							e.setAttribute('type','text/javascript');
							e.setAttribute('charset','UTF-8');
							e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);
							document.body.appendChild(e);
						" ><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_pinterest_icon"></i><span class="swp_share">Pin</span></span></span></span></a></div><div class="nc_tweetContainer swp_share_button swp_linkedin" data-network="linkedin"><a class="nc_tweet swp_share_link" rel="nofollow noreferrer noopener" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.kttn.com%2Fv2-obituary-services-clarence-randall-mantzey-jr%2F"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw swp_linkedin_icon"></i><span class="swp_share">Share</span></span></span></span></a></div></div><script type="text/javascript"> var swp_nonce = "3979e853f1";var swpFloatBeforeContent = true; var swp_ajax_url = "https://www.kttn.com/wp-admin/admin-ajax.php"; var swp_post_id = "263973";var swpClickTracking = false; swpPinIt={"enabled":false};</script>	<script src='https://stats.wp.com/e-202252.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'107434684',post:'263973',tz:'-6',srv:'www.kttn.com',j:'1:11.6'} ]);
		_stq.push([ 'clickTrackerInit', '107434684', '263973' ]);
	</script><script>(function(){var js = "window['__CF$cv$params']={r:'78157902ef2d582a',m:'iMOxp0l_TOPydQfYZoYk2wmqmDFvlnuR4VF3S4h5RXY-1672347704-0-AcAQYj870nmEP1JEHNp8XEybC1D8ly6LITfagcofFLEE8ZoBVv0p05h4LAu9Vvdvb38WQbzYiqkQCxBc5FduSR4iWZsPzoPg19QybwmWuApiWRu/GsQRX6DInsX8oSJfKXZ99ws1H8GUV4O+0jzunoXBmPbX2RGEdc1rg84Z626jn7LoXMvXnmhCjWboYBGqPA==',s:[0xba44c2fe64,0x95749e3be5],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/vaafb692b2aea4879b33c060e79fe94621666317369993" integrity="sha512-0ahDYl866UMhKuYcW078ScMalXqtFJggm7TmlUtp0UlD4eQk0Ixfnm5ykXKvGJNFjLMoortdseTfsRT8oCfgGA==" data-cf-beacon='{"rayId":"78157902ef2d582a","version":"2022.11.3","r":1,"token":"4469e13bb8f646b1bc869f8ba22890b8","si":100}' crossorigin="anonymous"></script>
</body>
</html>

<!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Thu, 29 Dec 2022 20:35:17 GMT -->
